Fout in database antennekaart voor netmonster app

Ik dacht de heletijd dat het aan mijn telefoon of aan de netmonster app lag maar ik heb het volgende.
Als ik de netmonster app installeer zie ik netjes de frequenties waarmee er verbonden is. Zodra ik blijkbaar de data binnenhaal van antennekaart dan zie ik continue maar 1 frequentie, dit heb ik voornamelijk bij T-Mobile en ook wel bij KPN sim. Ik krijg dan bijvoorbeeld continue LTE-A 1800 te zien met de database van antennekaart en zonder krijg ik gewoon netjes LTE-A 2100-800-1800.

Misschien dat hier naar gekeken kan worden?

1 Like

De verklaring hiervan ligt in een hele nare feature van Netmonster, het ‘gokken’ welke cellen bij elkaar horen. De meeste telefoons geven alleen informatie over de primaire cel waarmee hij verbonden is. Zonder de geimporteerde antennekaart database heeft Netmonster geen context hoe het netwerk eruit ziet. Als hij dan een aantal neighbor cells ziet doet Netmonster de (verkeerde) aanname dat deze cellen bij elkaar horen, en laat hij de bandencombinatie zien, in dit geval dus 2100+800+1800.

Doordat de Antennekaart database is geimporteerd snapt Netmonster dat het onmogelijk is dat die twee cellen bij elkaar horen, en zal dus de correcte informatie laten zien, namelijk de primaire cel en een eventueel secundaire cel in het lijstje daaronder. De enige manier om betrouwbaar te zien welke secundaire frequenties gebruikt is het servicemenu op Samsung (*#0011#), of root op een telefoon met een Qualcomm modem.

Netmonster is ook ontwikkeld door iemand anders, dus ik heb hier verder geen controle over. Dat je ander gedrag ziet wanneer de Antennekaart database is geimporteerd is in dit geval dus gewenst gedrag.

@jeffrey Ik snap wat je bedoelt, alleen het punt is dat de cellen die hij gokt kloppen. Maar zodra hij de database inleest van antennekaart klopt het niet meer en geeft hij bijvoorbeeld 1 frequentie aan. (toestel kan er minimaal 4 a 5 tegelijk aan). Misschien dat de database en netmonster niet goed samengaan of dat netmonster het niet goed implementeert tijden in inlezen van de data?

Ah oke, heb je dan een before en after screenshot waar ik het verschil kan vergelijken? Dan kan ik op basis daarvan eens kijken of ik een verklaring kan vinden of iets met de maker van NetMonster kan regelen.

Het is eigenlijk bizar dat anno 2021 fabrikanten van Android nog steeds niet iets hebben ingebouwd, waarbij je kan zien met welke frequenties je bent verbonden. Dat zou niet zo moeilijk moeten zijn, lijkt mij.

Zal er van de week even naar kijk!

Ik merk ook wel dat ik vaak alleen LTE-A 1800 zie staan, maar als ik Netmonster dan een tijdje actief houd dan geeft hij wel gewoon de juiste banden weer. Gaat hier wel om een Samsung telefoon, dus dat scheelt wellicht.

Wat ik ook zie is dat ik soms locaties krijg te zijn waarvan ik fysiek geen ontvangst kan hebben. Bijvoorbeeld een site van 25 kilometer verderop. Gebeurt slechts heel af en toe, maar wel opmerkelijk.

Ja dat zie ik idd ook wel eens gebeuren. Android geeft via de API alleen maar de primaire cell weer en soms wat neighbor cells. Helaas niet de secundaire cellen.

Dat laatste vind ik ook irritant, en ik heb ook geen idee hoe dat komt. Ik zal dat eens noemen bij de maker van Netmonster. Dat moet in mijn ogen helemaal niet kunnen gebeuren.

Als je op Samsung wil weten wat je secundaire cellen zijn moet je naar het service menu gaan (*#0011#), en dan stack 1 of 2 kiezen afhankelijk van of je SIM1 of SIM2 wilt zien. Je kunt daar ook dingen als de mimo rank zien, waarop je kan zien of je werkende 4x4 mimo hebt

Enige wat ik me bij de verkeerde locaties voor kan stellen is dat er een verkeerde eNB wordt opgevangen of zo. Nu speculeer ik maar wat hoor, het is wel vreemd.

Deze gebruik ik wel vaak om te checken wat het nu echt is. Wel geinig, met de ombouw van KPN. Stomme vraag wellicht, maar hoe check ik de mimo mode?

De RI komt op mijn S10 eigenlijk niet verder dan 2, al sta ik tegenover een mast. Mijn boerenverstand zegt me dat dat dan 2x2 is? Maar misschien dat KPN dit niet ondersteunt voor een S10 natuurlijk.

Vandaag in een verloren moment toch nog eens gecheckt en als ik aan een aantal voorwaarden voldoe (lopende data stream, RSRP onder -70dBm, zichtlijn met sectorantenne en telefoon gekanteld) krijg ik hem wel op 3 of 4.

Off-topic, maar toch even nuanceren.